Fantom-G6/-G7/-G8 Editor 1.20 & Librarian 1.30 for Macintosh OS X

This is the Fantom-G6/-G7/-G8 Librarian/Editor for Macintosh OS X (requires Fantom-G system version 1.30 or higher).